So I have tried installing Wearable Lanterns into Skyrim Special Edition in Windows 10. It is giving me a read write error and that it would be caused by the SKSE folder in Data being set to "read only" but when I go to untick the box I just find it ticked again when I reopen the properties menu.

You are watching: Skyrim se wearable lanterns read write error

Things I have already tried:

-Setting skse64, steam and skyrimlauncher to run as administrator

-Disabling Windows UAC

-Made sure my user had all the admin privileges

Does anyone know of a fix for this? I've looked everywhere and so far nothing works!


*

Yeah I got that as well! Seems that Chesko left some redundant scripts in the SE version and that SKSE64 causes them to activate. It doesn't help that the original version when ported doesn't recognise SkyUI SE and its MCM either.

edit: Bingo! Got it. _wl_compatibility.psc uses Game.GetFormFromFile() and its looking for SkyrimUI.esp and not SkyrimUI_SE.esp. Recompile the script with the changed name and MCM works just fine. Hallelujah!


As far as I can tell, this is just saying it couldn't read or write a json file (required for exporting and importing settings as per the LE mod change log), which it can't do because PapyrusUtil is missing due to it not being ported to SSE yet. Wearable Lanterns still works fine despite this (though I haven't tested with SSE 1.5.3 yet).

I left some instructions on the mod page comments on how to stop the error message from appearing. It requires recompiling one of the scripts to edit out the part of the code that checks the json file functionality.


I left some instructions on the mod page comments on how to stop the error message from appearing. It requires recompiling one of the scripts to edit out the part of the code that checks the json file functionality.

Thanks for pointing it out it was very helpful


Can you link to said instructions? I've been searching like crazy and I simply cannot find them. Thanks in advance! :-)


I also started getting those messages after I installed SKSE64. Wearable Lanterns made use of SKSE in oldrim. Back when it was ported to the Special Edition, SKSE64 wasn't yet available. So the error messages might be caused by leftover features from the old version of the mod that only show up now(?) Not sure how it can be fixed, you might have to wait for an update. The recently released Quick Light could be a good alternative for the time being.


I think this error occurs because Wearable Lanterns was released for Special Edition before SKSE was. The leftover Script Extender code is from Oldrim and was set to look for the folder Skyrim/data instead of Skyrim Special Edition/data.

See more: Turning Back Into A Kid And Starting Over, Sojin'S Blog

You can just ignore the message, but it won't stop popping up unless you know how to remove/fix the MCM plugin without screwing things up.


*

Welcome to /r/SkyrimMods! We are neurosoup.org's primary hub for all things modding, from troubleshooting for beginners to creation of mods by experts. We ask that you please take a minute to read through the rules and check out the resources provided before creating a post, especially if you are new here. :)